<!DOCTYPE html>
<html lang="en-US">
<head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var u=[],i="/porpoiseant/army.gif";function t(e,i,t,_,d,o,n){if(__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var r=parseInt(__ez.dot.getTargeting(e,"ap")),a=__ez.dot.getSlotIID(e),s=__ez.dot.getAdUnit(e),p=parseInt(__ez.dot.getTargeting(e,"compid")),z=0,f=0,g=function(e){if("undefined"==typeof _ezim_d)return!1;var i=__ez.dot.getAdUnitPath(e).split("/").pop();if("object"==typeof _ezim_d&&_ezim_d.hasOwnProperty(i))return _ezim_d[i];for(var t in _ezim_d)if(t.split("/").pop()===i)return _ezim_d[t];return!1}(e);"object"==typeof g&&(void 0!==g.creative_id&&(f=g.creative_id),void 0!==g.line_item_id&&(z=g.line_item_id)),__ez.dot.isDefined(a,s)&&__ez.dot.isValid(i)&&u.push({type:"impression",impression_id:a,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:_,ad_position:r,ad_size:"",bid_floor_filled:d,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:z,creative_id:f,data:__ez.dot.dataToStr(i)})}}function _(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(u)&&0<u.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(u));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}u=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),_()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var _=t[0],d=t[2];u.push({type:"impression",impression_id:d,domain_id:__ez.dot.getDID(),unit:_,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:_,GetPixels:function(){return u}}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(e,i){this.name=e,this.val=i};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(e,i){this.AddImpPixel(e,i,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(e,i){this.AddPVPixel(e,i),this.FirePixels()},AddImpPixel:function(e,i,t,n,o,a,d){if(0!=__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var s=parseInt(__ez.dot.getTargeting(e,"ap")),r=__ez.dot.getSizes(e)[0],_=r.l.toString()+"x"+r.j.toString(),p="0",l="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(p=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(l=_ezaq.country);var h=__ez.dot.getSlotIID(e),c=__ez.dot.getSlotElementId(e);__ez.dot.isDefined(h,c)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:h,domain_id:p,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:s,ad_size:_,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:d,country_code:l,data:i}))}},AddImpPixelById:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=e.split("/");if(__ez.dot.isDefined(e)&&3===n.length&&this.validateData(i)){var o=n[0],a=n[2];i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:i})}},AddPVPixel:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),__ez.dot.isDefined(e)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"pageview",pageview_id:e,domain_id:t,t_epoch:this.tEpoch,data:i}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(this.pixels)&&0<this.pixels.length&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(e,i){return new EzoicPixelData(e,i)},convertDataToStr:function(e){if(void 0===e)return[];try{for(var i in e)e[i].val=e[i].val+""}catch(e){}return e},validateData:function(e){for(var i=0;i<e.length;i++)if(e[i]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",e[i]),!1;return!0}};</script>
<script data-ezscrex="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false">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</script>
	<!--[if IE]>
	<meta http-equiv="X-UA-Compatible" content="IE=9; IE=8; IE=7; IE=edge" /><![endif]-->
	
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<title>How&#8217;s Rihanna Doing On Twitter? (2019-12-22) &#8211; Global Real News</title>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Global Real News &raquo; Feed" href="https://globalrealnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Global Real News &raquo; Comments Feed" href="https://globalrealnews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Global Real News &raquo; How&#8217;s Rihanna Doing On Twitter? (2019-12-22) Comments Feed" href="https://globalrealnews.com/news/2019/12/22/hows-rihanna-doing-on-twitter-2019-12-22/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://globalrealnews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://globalrealnews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='ezoic-integration-css'  href='https://globalrealnews.com/wp-content/plugins/ezoic-integration/public/css/ezoic-integration-public.css?ver=1.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='basic-fonts-css'  href='//fonts.googleapis.com/css?family=PT+Serif%3A400%2C700%7COpen+Sans%3A400%2C400italic%2C700%2C700italic&#038;subset=latin%2Ccyrillic&#038;ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='basic-style-css'  href='https://globalrealnews.com/wp-content/themes/basic/style.css?ver=1' type='text/css' media='all' />
<script type='text/javascript' src='https://globalrealnews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://globalrealnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://globalrealnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://globalrealnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://globalrealnews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Aluna Sagita Gutawa &#8211; Twitter&#8217;s Verdict (2019-12-22)' href='https://globalrealnews.com/news/2019/12/22/aluna-sagita-gutawa-twitters-verdict-2019-12-22/' />
<link rel='next' title='The Community Reacts To Cara Delevingne On Twitter (2019-12-22)' href='https://globalrealnews.com/news/2019/12/22/the-community-reacts-to-cara-delevingne-on-twitter-2019-12-22/' />
<meta name="generator" content="WordPress 5.2.5" />
<link rel="canonical" href="https://globalrealnews.com/news/2019/12/22/hows-rihanna-doing-on-twitter-2019-12-22/" />
<link rel='shortlink' href='https://globalrealnews.com/?p=63932' />
<link rel="alternate" type="application/json+oembed" href="https://globalrealnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fglobalrealnews.com%2Fnews%2F2019%2F12%2F22%2Fhows-rihanna-doing-on-twitter-2019-12-22%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://globalrealnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fglobalrealnews.com%2Fnews%2F2019%2F12%2F22%2Fhows-rihanna-doing-on-twitter-2019-12-22%2F&#038;format=xml" />

<!-- StarBox - the Author Box for Humans 3.2.6, visit: http://wordpress.org/plugins/starbox/ -->
<!-- /StarBox - the Author Box for Humans -->

<link rel='stylesheet' id='ABHfrontend.min.css-css'  href='https://globalrealnews.com/wp-content/plugins/starbox//themes/minimal/css/frontend.min.css?ver=3.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='ABHhidedefault.min.css-css'  href='https://globalrealnews.com/wp-content/plugins/starbox//themes/admin/css/hidedefault.min.css?ver=3.2.6' type='text/css' media='all' />

<!-- [BEGIN] Scripts added via Insert Adsense Auto Ads plugin -->
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-6660504528848291",
          enable_page_level_ads: true
     });
</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-145052790-2"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-145052790-2');
</script>
<!-- [END] Scripts added via Insert Adsense Auto Ads plugin -->



<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-124335557-26";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-124335557-26']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'globalrealnews.com']);
_gaq.push(['f._setDomainName', 'globalrealnews.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod6',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','globalrealnews.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://globalrealnews.com/news/2019/12/22/hows-rihanna-doing-on-twitter-2019-12-22/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 130890;
var ezdomain = 'globalrealnews.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":130890,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"256393c5-aac3-4c3f-5f20-4c6a8dd877ea","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":417,"serverid":"3.91.33.4:30997","state":"VA","t_epoch":1577082082,"template_id":126,"time_on_site_visit":0,"url":"https://globalrealnews.com/news/2019/12/22/hows-rihanna-doing-on-twitter-2019-12-22/","user_id":0,"word_count":482,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_130890=" + new Date().getTime() + "|256393c5-aac3-4c3f-5f20-4c6a8dd877ea; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>
<body class="post-template-default single single-post postid-63932 single-format-standard layout-">
<div class="wrapper clearfix">

		<!-- BEGIN header -->
	<header id="header" class="clearfix">

        <div class="header-top-wrap">
        
                        <div class="sitetitle maxwidth grid ">

                <div class="logo">

                                            <a id="logo" href="https://globalrealnews.com/" class="blog-name">
                    Global Real News                        </a>
                    
                    
                                            <p class="sitedescription">Science News</p>
                    
                </div>
                            </div>

                </div>

		        <div class="topnav">

			<div id="mobile-menu" class="mm-active">Menu</div>

			<nav>
									<ul class="top-menu maxwidth clearfix">
													<li class="page_item">
								<a href="https://globalrealnews.com/">Home</a>
							</li>
						<li class="page_item page-item-20"><a href="https://globalrealnews.com/about-us/">About Us</a></li>
<li class="page_item page-item-14"><a href="https://globalrealnews.com/contact-us/">Contact Us</a></li>
<li class="page_item page-item-10"><a href="https://globalrealnews.com/meet-the-team/">Meet The Team</a></li>
<li class="page_item page-item-12"><a href="https://globalrealnews.com/privacy-policy/">Privacy Policy</a></li>
					</ul>
							</nav>

		</div>
		
	</header>
	<!-- END header -->

	

	<div id="main" class="maxwidth clearfix">

		<!-- BEGIN content -->
	
	<main id="content" class="content">

	<div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<!-- Ezoic - beforepost - top_of_page -->
<div id="ezoic-pub-ad-placeholder-102">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- responsivesquare -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6660504528848291"
     data-ad-slot="7635526878"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - beforepost - top_of_page --></div>

<article class="post-63932 post type-post status-publish format-standard category-news" itemscope itemtype="http://schema.org/Article">		<h1 itemprop="headline">How&#8217;s Rihanna Doing On Twitter? (2019-12-22)</h1>
		<aside class="meta"><span class="date">December 22, 2019</span><span class="category"><a href="https://globalrealnews.com/category/news/" rel="category tag">News</a></span><span class="comments"><a href="https://globalrealnews.com/news/2019/12/22/hows-rihanna-doing-on-twitter-2019-12-22/#respond">Comments: 0</a></span></aside>	<div class="entry-box clearfix" itemprop='articleBody'>

		<div class="html-before-content"></div>
<div class="entry">
<p><img class="alignleft" src="https://pbs.twimg.com/profile_images/1133109643734130688/BwioAwkz_400x400.jpg" height="200" width="200">Hello! Today we did a major analysis of Rihanna&#8217;s Twitter activity. Let&#8217;s get started. First, the simple stuff: as of 2019-12-22, Rihanna (@rihanna) has 94965262 Twitter followers, is following 1067 people, has tweeted 10449 times, has liked 1020 tweets, has uploaded 1944 photos and videos and has been on Twitter since October 2009.</p>
<p>Going from the top of the page to the bottom, their latest tweet, at the time of writing, has 601 replies, 6,201 retweets and 64,838 likes, their second latest tweet has 844 replies, 3,004 reweets and 34,684 likes, their third latest tweet has 532 replies, 5,298 retweets and 38,204 likes, their fourth latest tweet has 956 replies, 9,227 retweets and 78,897 likes and their fifth latest tweet has 610 replies, 8,663 retweets and 83,950 likes. But we won&#8217;t bore you going through all these numbers 🙂</p><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<!-- Ezoic - incontent - native_mid -->
<div id="ezoic-pub-ad-placeholder-103">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- responsivesquare -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6660504528848291"
     data-ad-slot="7635526878"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - incontent - native_mid -->
<!-- Ezoic - incontentlinks - link_mid -->
<div id="ezoic-pub-ad-placeholder-104"></div>
<!-- End Ezoic - incontentlinks - link_mid --></div>

<p><b><u>MOST POPULAR:</u></b></p>
<p>Going through Rihanna&#8217;s last couple pages of tweets (including retweets), the one we consider the most <i>popular</i>, having incited a very respectable 3260 direct replies at the time of writing, is this:</p>
<p><center></p>
<blockquote class="twitter-tweet" data-lang="en">
<p lang="en" dir="ltr">
<p><a href="https://twitter.com/rihanna/status/1201202849822068736"></a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></center></p>
<p>That seems to have caused quite a ruckus, having also had 44471 retweets and 533846 likes.</p>
<p><b><u>LEAST POPULAR:</u></b></p>
<p>And what about Rihanna&#8217;s <i>least</i> popular tweet as of late (including stuff they retweeted)? We believe it&#8217;s this one:</p>
<p><center></p>
<blockquote class="twitter-tweet" data-lang="en">
<p lang="en" dir="ltr">
<p><a href="https://twitter.com/rihanna/status/1187173631266189312"></a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></center></p>
<p>That only had 229 direct replies, 604 retweets and 7267 likes.</p>
<p><b><u>THE VERDICT:</u></b></p>
<p>We did a lot of of digging into Rihanna&#8217;s Twitter activity, looking through what people are saying in response to them, their likes/retweet numbers compared to the past, the amount of positive/negative responses and so on. We won&#8217;t drone on and on about the numbers, so our conclusion is this: <u>we say the online sentiment for Rihanna on Twitter right now is <span style="color: #008000;"><b>A-OK &#8211; most people like them</b></u></span>.</p>
<p>That&#8217;s all for now. Thanks for coming, and leave a comment if you agree or disagree with me. However, we won&#8217;t publish anything overly rude.</p>
</div>
<div class="html-after-content"></div>

                         <div class="abh_box abh_box_down abh_box_minimal"><ul class="abh_tabs"> <li class="abh_about abh_active"><a href="#abh_about">About</a></li> <li class="abh_posts"><a href="#abh_posts">Latest Posts</a></li></ul><div class="abh_tab_content"><section class="vcard abh_about_tab abh_tab" style="display:block"><div class="abh_image"><a href = "https://globalrealnews.com/author/admin/" class="url" title = "Glenn Clinton" > <img src="https://globalrealnews.com/wp-content/uploads/gravatar/1.jpg" class="photo" width="250" alt="Glenn Clinton" /></a > </div><div class="abh_social"> </div><div class="abh_text"><h3 class="fn name" ><a href="https://globalrealnews.com/author/admin/" class="url">Glenn Clinton</a></h3><div class="abh_job" ></div><div class="description note abh_description" >HI! I'm Glenn and I'm the founder of our boutique news agency at globalrealnews.com. I have had an interest in nature and science from a very early age, and thoroughly enjoy reporting on the latest scientific research. I'm a graduate from Michigan State University and work in mechanical engineering. <br /><br />Apart from science reporting I also occasionally cover celebrity/entertainment news.<br /><br />2485 Prudence Street, Farmington Hills MI 48335<br />313-309-1892<br />glenn@globalrealnews.com</div></div> </section><section class="abh_posts_tab abh_tab" ><div class="abh_image"><a href="https://globalrealnews.com/author/admin/" class="url" title="Glenn Clinton"><img src="https://globalrealnews.com/wp-content/uploads/gravatar/1.jpg" class="photo" width="250" alt="Glenn Clinton" /></a></div><div class="abh_social"> </div><div class="abh_text"><h4 >Latest posts by Glenn Clinton <span class="abh_allposts">(<a href="https://globalrealnews.com/author/admin/">see all</a>)</span></h4><div class="abh_description note" ><ul></div></div> </section></div> </div><div class='social_share clearfix'><p class='socshare-title'></p>
			<a rel="nofollow" class="psb fb" target="_blank" href="http://www.facebook.com/sharer.php?u=https://globalrealnews.com/news/2019/12/22/hows-rihanna-doing-on-twitter-2019-12-22/&amp;t=How%26%238217%3Bs+Rihanna+Doing+On+Twitter%3F+%282019-12-22%29&amp;src=sp" title="Share in Facebook"></a>
			<a rel="nofollow" class="psb vk" target="_blank" href="http://vkontakte.ru/share.php?url=https://globalrealnews.com/news/2019/12/22/hows-rihanna-doing-on-twitter-2019-12-22/" title="Share in VK"></a>
			<a rel="nofollow" class="psb ok" target="_blank" href="https://connect.ok.ru/offer?url=https://globalrealnews.com/news/2019/12/22/hows-rihanna-doing-on-twitter-2019-12-22/&amp;title=How%26%238217%3Bs+Rihanna+Doing+On+Twitter%3F+%282019-12-22%29" title="Share in OK"></a>
			<a rel="nofollow" class="psb gp" target="_blank" href="https://plus.google.com/share?url=https://globalrealnews.com/news/2019/12/22/hows-rihanna-doing-on-twitter-2019-12-22/"  title="Share in Google+"></a>
			<a rel="nofollow" class="psb tw" target="_blank" href="http://twitter.com/share?url=https://globalrealnews.com/news/2019/12/22/hows-rihanna-doing-on-twitter-2019-12-22/&amp;text=How%26%238217%3Bs+Rihanna+Doing+On+Twitter%3F+%282019-12-22%29" title="Share in Twitter"></a>
			</div><div class='code-block code-block-2' style='margin: 8px 0; clear: both;'>
<!-- Ezoic - aftercontent - bottom_of_page -->
<div id="ezoic-pub-ad-placeholder-106">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- responsivesquare -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6660504528848291"
     data-ad-slot="7635526878"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - aftercontent - bottom_of_page --></div>

	</div> 		<aside class="meta"></aside>
	<!-- Schema.org Article markup -->
		<div class="markup">

			<meta itemscope itemprop="mainEntityOfPage" content="https://globalrealnews.com/news/2019/12/22/hows-rihanna-doing-on-twitter-2019-12-22/" />

			<div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
				<link itemprop="url" href="https://globalrealnews.com/wp-content/themes/basic/img/default.jpg">
				<link itemprop="contentUrl" href="https://globalrealnews.com/wp-content/themes/basic/img/default.jpg">
				<meta itemprop="width" content="80">
				<meta itemprop="height" content="80">
			</div>

			<meta itemprop="datePublished" content="2019-12-22T20:24:48+00:00">
			<meta itemprop="dateModified" content="2019-12-22T20:24:48+00:00" />
			<meta itemprop="author" content="Glenn Clinton">

			<div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
				<meta itemprop="name" content="Global Real News">
				<meta itemprop="address" content="Russia">
				<meta itemprop="telephone" content="+7 (000) 000-000-00">
				<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
					<link itemprop="url" href="https://globalrealnews.com/wp-content/themes/basic/img/logo.jpg">
					<link itemprop="contentUrl" href="https://globalrealnews.com/wp-content/themes/basic/img/logo.jpg">
				</div>
			</div>

		</div>
		<!-- END markup -->
		
	</article>


<div id="comments" class="comments-area">

	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/news/2019/12/22/hows-rihanna-doing-on-twitter-2019-12-22/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://globalrealnews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><div class="rcomment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Message" aria-required="true"></textarea></div><div class="rinput rauthor"><input type="text" placeholder="Your Name" name="author" id="author" class="required" value="" /></div>
<div class="rinput remail"><input type="text" placeholder="Your E-mail" name="email" id="email" class="required" value="" /></div>
<div class="rinput rurl"><input type="text" placeholder="Your Website" name="url" id="url" class="last-child" value=""  /></div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes"  /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='63932' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="42526f4cb3" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="120"/></p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments -->		


	</main> <!-- #content -->
	
<!-- BEGIN #sidebar -->
<aside id="sidebar" class="">
	<ul id="widgetlist">

    <li id="search-2" class="widget widget_search"><form method="get" class="searchform" action="https://globalrealnews.com//">
    <input type="text" value="" placeholder="Search" name="s" class="s" />
    <input type="submit" class="submit search_submit" value="&raquo;" />
</form>
</li><li id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- Ezoic - vertical - native_side_mid -->
<div id="ezoic-pub-ad-placeholder-105">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- vertical -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6660504528848291"
     data-ad-slot="8381740135"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- vertical -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6660504528848291"
     data-ad-slot="8381740135"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - vertical - native_side_mid --></div></li>
	</ul>
</aside>
<!-- END #sidebar -->

</div> 
<!-- #main -->


<footer id="footer" class="">

	
	
	    	<div class="copyrights maxwidth grid">
		<div class="copytext col6">
			<p id="copy">
				<!--noindex--><a href="https://globalrealnews.com/" rel="nofollow">Global Real News</a><!--/noindex--> &copy; 2019				<br/>
				<span class="copyright-text"></span>
							</p>
		</div>

		<div class="themeby col6 tr">
			<p id="designedby">
				Theme by				<!--noindex--><a href="https://shorenewsnow.com">buy google news sites</a><!--/noindex-->
			</p>
						<div class="footer-counter"></div>
		</div>
	</div>
    	
</footer>


</div> 
<!-- .wrapper -->

<a id="toTop">&#10148;</a>

<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/globalrealnews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://globalrealnews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.4'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://globalrealnews.com/wp-content/themes/basic/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='https://globalrealnews.com/wp-content/themes/basic/js/functions.js?ver=1'></script>
<script type='text/javascript' src='https://globalrealnews.com/wp-includes/js/comment-reply.min.js?ver=5.2.5'></script>
<script type='text/javascript' src='https://globalrealnews.com/wp-includes/js/wp-embed.min.js?ver=5.2.5'></script>
<script async="async" type='text/javascript' src='https://globalrealnews.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=32', false, [], true, false, false, false);
</script>

<script>var _audins_dom="globalrealnews_com",_audins_did=130890;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.globalrealnews_com,DomainId.130890" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript'>(function(){function b(e,c){for(var d=0;d<c.length;d++){var f=c[d];if(0==f.complete||"undefined"!=typeof f.readyState&&4>f.readyState){var g=f.getAttribute("src")||f.currentSrc;"undefined"!=typeof f.readyState&&0==f.readyState?f.addEventListener("loadstart",function(h){var k=h.getAttribute("src")||h.currentSrc;window.ezorqs(h,k)}):(g=f.getAttribute("src")||f.currentSrc,window.ezorqs(f,g));f.addEventListener("load",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,
		k)});f.addEventListener("loadeddata",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,k)});f.addEventListener("error",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,k)})}}}function a(e){for(var c=0;c<document.styleSheets.length;c++)if(document.styleSheets[c].href==e)return!0;return!1}b("img",document.querySelectorAll("img"));b("video",document.querySelectorAll("video"));b("audio",document.querySelectorAll("audio"));
		(function(e){for(var c=0;c<e.length;c++){var d=e[c];if(("preload"==d.getAttribute("rel")||"stylesheet"==d.getAttribute("rel"))&&null!=d.getAttribute("href")&&a(d.getAttribute("href"))){window.ezorqs(d,d.getAttribute("href"));var f=document.createElement("img");f.onerror=function(g){"undefined"!=typeof g.path&&"undefined"!=typeof g.path[0].currentSrc?window.ezorqe(d,g.path[0].currentSrc):"undefined"!=typeof g.srcElement&&"undefined"!=typeof g.srcElement.href&&window.ezorqe(d,g.srcElement.href)};f.src=
		d.getAttribute("href")}}})(document.querySelectorAll("link"));Element.prototype.addEventListener&&("function"==typeof window.onload&&(window.addEventListener("load",window.onload),window.onload=null),"function"==typeof document.onload&&(document.addEventListener.addEventListener("load",document.onload),document.onload=null))})();</script><script type="text/javascript" onload="__ezcl.handle(true);" async src="/utilcave_com/inc/ezcl.webp?cb=4"></script></body>
</html>